StatusBarIndicatorProps Interface

Properties of StatusBarIndicator component.

Extends

Properties

Name Type Description
children React.ReactNode | undefined Indicator content.  
defaultIsOpen boolean | undefined Default state of an indicator popup.  
onClick () => void | undefined Function called when indicator is clicked.  
popup React.ReactNode | undefined Content to display in a popup when indicator is clicked.  
title string | undefined Title of an indicator.  

Inherited properties

Name Type Inherited from Description
className string | undefined CommonProps Custom CSS class name
itemId string | undefined CommonProps Optional unique identifier for item.
style React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 23 May, 2024