UiItemsProvider Interface

Deprecated  in 3.6. Use UiItemsProvider instead.

Describes interface of objects that want to provide UI component to the running IModelApp.

Implemented by

Properties

Name Type Description
id Readonly string id of provider  
onUnregister undefined | () => void    
provideBackstageItems undefined | () => BackstageItem[]    
provideStatusBarItems undefined | (stageId: string, stageUsage: string, stageAppData?: any) => CommonStatusBarItem[]    
provideToolbarButtonItems undefined | (stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any) => CommonToolbarItem[]    
provideWidgets undefined | (stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, zoneLocation?: AbstractZoneLocation, stageAppData?: any) => undefined    

Defined in

Last Updated: 15 March, 2024