StandardContentToolsProvider Class

Provide standard tools for the ContentManipulationWidgetComposer.

Extends

Methods

Name Description
constructor(providerId: string, defaultContentTools?: DefaultContentTools, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardContentToolsProvider    
provideStatusBarItemsInternal(_stageId: string, _stageUsage: string, _stageAppData?: any): StatusBarItem[]    
provideToolbarItemsInternal(_stageId: string, _stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): ToolbarItem[]    
register(providerId: string, defaultContentTools?: DefaultContentTools, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardContentToolsProvider Static static function to register the StandardContentToolsProvider  

Inherited methods

Name Inherited from Description
onUnregister(): void BaseUiItemsProvider Function called when the provider is unregistered.
provideStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): StatusBarItem[] BaseUiItemsProvider Provides status bar items.
provideToolbarItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): ToolbarItem[] BaseUiItemsProvider Provides toolbar items.
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, stageAppData?: any): undefined BaseUiItemsProvider Provides widgets.
provideWidgetsInternal(_stageId: string, _stageUsage: string, _location: StagePanelLocation, _section?: StagePanelSection, _stageAppData?: any): Widget[] BaseUiItemsProvider  
unregister(): void BaseUiItemsProvider  

Inherited properties

Name Type Inherited from Description
_providerId Protected string BaseUiItemsProvider  
id Accessor ReadOnly string BaseUiItemsProvider Id of provider.
isSupportedStage undefined | (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean BaseUiItemsProvider  

Defined in

Last Updated: 05 April, 2024