IMutableCategorizedPropertyItem Interface

Data structure which describes methods and properties to be held by Mutable CategorizedPropertyItems

Extends

Implemented by

Methods

Name Description
getChildren(): IMutableCategorizedPropertyItem[]    

Inherited methods

Name Inherited from Description
getDescendantsAndSelf(): IMutableFlatGridItem[] IMutableFlatPropertyGridItem  
getLastVisibleDescendantOrSelf(): IMutableFlatGridItem IMutableFlatPropertyGridItem  
getVisibleDescendantsAndSelf(): IMutableFlatGridItem[] IMutableFlatPropertyGridItem  

Properties

Name Type Description
derivedRecord Readonly PropertyRecord    
parentCategorySelectionKey Readonly string    
parentSelectionKey Readonly string    
type Readonly CategorizedPropertyTypes    

Inherited properties

Name Type Inherited from Description
depth Readonly number IMutableFlatPropertyGridItem  
isExpanded boolean IMutableFlatPropertyGridItem  
isLastInRootCategory boolean IMutableFlatPropertyGridItem  
key Readonly string IMutableFlatPropertyGridItem  
label Readonly string IMutableFlatPropertyGridItem  
lastInNumberOfCategories number IMutableFlatPropertyGridItem  
selectionKey Readonly string IMutableFlatPropertyGridItem  

Defined in

Last Updated: 05 April, 2024