IMutableGridCategoryItem Interface

Data structure which describes methods and properties to be held by Mutable GridCategoryItems

Extends

Implemented by

Inherited methods

Name Inherited from Description
getChildren(): IMutableFlatGridItem[] IMutableFlatPropertyGridItem  
getDescendantsAndSelf(): IMutableFlatGridItem[] IMutableFlatPropertyGridItem  
getLastVisibleDescendantOrSelf(): IMutableFlatGridItem IMutableFlatPropertyGridItem  
getVisibleDescendantsAndSelf(): IMutableFlatGridItem[] IMutableFlatPropertyGridItem  

Properties

Name Type Description
derivedCategory PropertyCategory    
isRootCategory boolean    
name string    
type Category    

Inherited properties

Name Type Inherited from Description
depth Readonly number IMutableFlatPropertyGridItem  
isExpanded boolean IMutableFlatPropertyGridItem  
isLastInRootCategory boolean IMutableFlatPropertyGridItem  
key Readonly string IMutableFlatPropertyGridItem  
label Readonly string IMutableFlatPropertyGridItem  
lastInNumberOfCategories number IMutableFlatPropertyGridItem  
parentCategorySelectionKey Readonly undefined | string IMutableFlatPropertyGridItem  
parentSelectionKey Readonly undefined | string IMutableFlatPropertyGridItem  
selectionKey Readonly string IMutableFlatPropertyGridItem  

Defined in

Last Updated: 21 March, 2024