MutableGridCategory Class

Mutable wrapper object for PropertyCategory which provides methods for working with and managing category and record children hierarchies

Extends

Implements

Methods

Name Description
constructor(category: PropertyCategory, recordsDict: CategoryRecordsDict, gridItemFactory: IMutableGridItemFactory, parentSelectionKey?: string, depth: number = 0): MutableGridCategory    
getChildren(): IMutableFlatGridItem[]    
getSelf(): MutableGridCategory    

Inherited methods

Name Inherited from Description
getDescendants(): IMutableFlatGridItem[] Protected MutableFlatPropertyGridItem  
getDescendantsAndSelf(): IMutableFlatGridItem[] MutableFlatPropertyGridItem Gets a flat list of all FlatGridItems beneath this flat grid item including itself in depth first visiting order.
getLastVisibleDescendantOrSelf(): IMutableFlatGridItem MutableFlatPropertyGridItem  
getVisibleDescendants(): IMutableFlatGridItem[] MutableFlatPropertyGridItem Gets a flat list of visible FlatGridItems beneath this flat grid item.
getVisibleDescendantsAndSelf(): IMutableFlatGridItem[] MutableFlatPropertyGridItem Gets a flat list of visible FlatGridItems beneath this flat grid item and itself in depth first visiting order.

Properties

Name Type Description
derivedCategory Accessor ReadOnly PropertyCategory    
isRootCategory Accessor ReadOnly boolean Category is considered to be root category if its depth is 0  
label Accessor ReadOnly string    
name Accessor ReadOnly string    
selectionKey Accessor ReadOnly string    
type Accessor ReadOnly Category    

Inherited properties

Name Type Inherited from Description
_isExpanded Protected boolean MutableFlatPropertyGridItem  
_isLastInRootCategory Protected boolean MutableFlatPropertyGridItem  
_lastInNumberOfCategories Protected number MutableFlatPropertyGridItem  
[DRAFTABLE] boolean MutableFlatPropertyGridItem  
depth Accessor ReadOnly number MutableFlatPropertyGridItem  
isExpanded Accessor boolean MutableFlatPropertyGridItem  
key Readonly string MutableFlatPropertyGridItem  
parentCategorySelectionKey Accessor ReadOnly undefined | string MutableFlatPropertyGridItem  
parentSelectionKey Accessor ReadOnly undefined | string MutableFlatPropertyGridItem  

Defined in

Last Updated: 21 March, 2024