ExportGraphicsLines Interface

A collection of line segments, suitable for direct use with graphics APIs. The structure of this data matches GL_LINES in OpenGL. See IModelDb.exportGraphics

Properties

Name Type Description
indices Int32Array Zero-based vertex indices, every two indices represent a line segment  
points Float64Array Vertices for these lines, laid out in the pattern XYZXYZ  

Defined in

Last Updated: 15 March, 2024