acquireLocks Method

Acquire locks on one or more elements from the lock server, if required and not already held. If any required lock is not available, this method throws an exception and none of the requested locks are acquired.

Note: acquiring the exclusive lock on an element requires also obtaining a shared lock on all its owner elements. This method will attempt to acquire all necessary locks for both sets of input ids.

acquireLocks(arg: { exclusive?: Id64Arg, shared?: Id64Arg }): Promise<void>

Parameter Type Description
arg { exclusive?: Id64Arg, shared?: Id64Arg }  

Returns - Promise<void>

Defined in

Last Updated: 15 March, 2024