DisplayStyleSettingsProps Interface

JSON representation of the DisplayStyleSettings associated with a DisplayStyleProps. These settings are not stored directly as members of the DisplayStyleProps. Instead, they are stored as members of DisplayStyleProps.jsonProperties.styles.

Properties

Name Type Description
analysisFraction undefined | number See DisplayStyleSettings.analysisFraction.  
analysisStyle undefined | AnalysisStyleProps See DisplayStyleSettings.analysisStyle.  
backgroundColor undefined | number See DisplayStyleSettings.backgroundColor.  
backgroundMap undefined | PersistentBackgroundMapProps See DisplayStyleSettings.backgroundMap.  
clipStyle undefined | ClipStyleProps See DisplayStyleSettings.clipStyle.  
contextRealityModels undefined | ContextRealityModelProps[] See DisplayStyleSettings.contextRealityModels.  
excludedElements string | Id64Array Ids of elements not to be displayed in the view.  
mapImagery undefined | MapImageryProps See DisplayStyleSettings.mapImagery.  
modelOvr undefined | DisplayStyleModelAppearanceProps[] Overrides applied to the appearance of models in the view.  
monochromeColor undefined | number See DisplayStyleSettings.monochromeColor.  
monochromeMode undefined | MonochromeMode See DisplayStyleSettings.monochromeMode.  
planarClipOvr undefined | DisplayStylePlanarClipMaskProps[] See DisplayStyleSettings.planarClipMasks.  
realityModelDisplay undefined | DisplayStyleRealityModelDisplayProps[] Display settings applied to specific reality models in the view.  
renderTimeline undefined | string See DisplayStyleSettings.renderTimeline.  
scheduleScript undefined | RenderSchedule.ScriptProps See DisplayStyleSettings.scheduleScriptProps.  
subCategoryOvr undefined | DisplayStyleSubCategoryProps[] Overrides applied to the appearances of subcategories in the view.  
timePoint undefined | number See DisplayStyleSettings.timePoint.  
viewflags undefined | ViewFlagProps See DisplayStyleSettings.viewFlags.  
whiteOnWhiteReversal undefined | WhiteOnWhiteReversalProps See DisplayStyleSettings.whiteOnWhiteReversal.  

Defined in

Last Updated: 15 March, 2024