RealityData Interface

RealityData This class implements a Reality Data stored in the Reality Data API Data is accessed directly through methods of the reality data instance. Access to the data required a properly entitled token though the access to the blob is controlled through an Azure blob URL, the token may be required to obtain this Azure blob URL or refresh it. The Azure blob URL is considered valid for an hour and is refreshed after 50 minutes. In addition to the reality data properties, and Azure blob URL and internal states, a reality data also contains the identification of the iTwin to identify the context(used for access permissions resolution)

Methods

Name Description
getBlobUrl(accessToken: string, blobPath: string): Promise<URL>    

Properties

Name Type Description
id undefined | string    
rootDocument undefined | string    
type undefined | string    

Defined in

Last Updated: 15 March, 2024