findFormatterSpecByQuantityType Method

Synchronous call to get a FormatterSpec of a QuantityType. If the FormatterSpec is not yet cached an undefined object is returned. The cache is populated by the async call loadFormatAndParsingMapsForSystem.

findFormatterSpecByQuantityType(type: QuantityTypeArg, _unused?: boolean): undefined | FormatterSpec

Parameter Type Description
type QuantityTypeArg  
_unused boolean  

Returns - undefined | FormatterSpec

Defined in

Last Updated: 16 April, 2024