getParserSpecByQuantityType Method

Asynchronous Call to get a ParserSpec for a QuantityType.

getParserSpecByQuantityType(type: QuantityTypeArg, isImperial?: boolean): Promise<undefined | ParserSpec>

@returns A FormatterSpec Promise.

Parameter Type Description
type QuantityTypeArg One of the built-in quantity types supported.
isImperial boolean Argument to specify use of imperial or metric unit system. If left undefined the active unit system is used.

Returns - Promise<undefined | ParserSpec>

A FormatterSpec Promise.

Defined in

Last Updated: 16 April, 2024