addOnAnalysisStyleChangedListener Method

Add an event listener to be invoked whenever the AnalysisStyle associated with this viewport changes. The analysis style may change for any of several reasons:

addOnAnalysisStyleChangedListener(listener: (newStyle: undefined | AnalysisStyle) => void): () => void

@returns A function that can be invoked to remove the event listener.

Parameter Type Description
listener (newStyle: undefined | AnalysisStyle) => void Callback accepting the new analysis style, or undefined if there is no analysis style.

Returns - () => void

A function that can be invoked to remove the event listener.

Defined in

Last Updated: 16 April, 2024