Dialog Class

Dialog React component with optional resizing and dragging functionality

Extends

Methods

Name Description
constructor(props: DialogProps): Dialog    
_handleContainerPointerDown(event: PointerEvent<Element>): void Protected    
componentDidMount(): void    
componentWillUnmount(): void    
getFooterButtons(buttonCluster: undefined | DialogButtonDef[], primaryStyleType: undefined | "default" | "cta" | "high-visibility" | "borderless" = "cta", noCoreButtonClasses: boolean = false): undefined | ReactNode[] Protected    
handleRefSet(containerDiv: | HTMLDivElement): void    
render(): ReactElement<any, string | JSXElementConstructor<any>>    

Properties

Name Type Description
defaultProps Static Partial<DialogProps>    

Defined in

Last Updated: 21 March, 2024