Popup Class

Popup React component displays a popup relative to an optional target element.

Extends

Methods

Name Description
constructor(props: PopupProps): Popup    
componentDidMount(): void    
componentDidUpdate(previousProps: PopupProps, prevState: PopupState): void    
componentWillUnmount(): void    
render(): | ReactPortal    

Properties

Name Type Description
defaultProps Static Partial<PopupProps>    

Defined in

Last Updated: 05 April, 2024