HyperModeling Class

The API entry point for the hypermodeling package. Applications must call HyperModeling.initialize and await the result before using the package. The behavior of the package can be customized via a HyperModelingConfig supplied to HyperModeling.initialize, HyperModeling.updateConfiguration, or HyperModeling.replaceConfiguration. Hypermodeling mode can be enabled or disabled via HyperModeling.startOrStop, which returns a HyperModelingDecorator when enabling hypermodeling. Consult the package's README.md for a description of the available functionality.

Methods

Name Description
constructor(): HyperModeling    
initialize(config?: HyperModelingConfig): Promise<void> Static Invoke this method to initialize the hypermodeling package for use.  
isEnabledForViewport(viewport: ScreenViewport): boolean Static Returns whether hypermodeling is currently enabled for the specified viewport.  
isSupportedForIModel(imodel: IModelConnection): Promise<boolean> Static Returns true if the specified iModel contains any SectionDrawingLocations.  
replaceConfiguration(config?: HyperModelingConfig): void Static Replaces the current package configuration, overwriting all previous settings.  
start(viewport: ScreenViewport): Promise<undefined | HyperModelingDecorator> Static Start hypermodeling mode for the specified viewport if it is not currently enabled.  
startOrStop(viewport: ScreenViewport, start?: boolean): Promise<undefined | HyperModelingDecorator> Static Start or stop hypermodeling mode for the specified viewport.  
stop(viewport: ScreenViewport): void Static Stop hypermodeling mode for the specified viewport if it is currently enabled.  
updateConfiguration(config: HyperModelingConfig): void Static Overrides specific aspects of the current package configuration.  

Properties

Name Type Description
graphicsConfig Accessor StaticReadOnly SectionGraphicsConfig This graphics options applied to graphics displayed by all HyperModelingDecorators.  
isInitialized Accessor StaticReadOnly boolean Returns whether the hypermodeling package is initialized.  
markerConfig Accessor StaticReadOnly SectionMarkerConfig The current marker display configuration applied to any newly-created HyperModelingDecorators.  
markerHandler Accessor StaticReadOnly SectionMarkerHandler The handler that defines interactions with SectionMarkers.  

Defined in

Last Updated: 16 April, 2024