TimelineComponentProps Interface

TimelineComponentProps configure the timeline

Properties

Name Type Description
alwaysMinimized undefined | boolean Always display in miniMode with no expand menu (For future use. Deprecated  
appMenuItemOption undefined | TimelineMenuItemOption How to include the supplied app menu items in the Timeline Context Menu (prefix, append or replace).  
appMenuItems undefined | TimelineMenuItemProps[] App-supplied speed entries in the Timeline Context Menu.  
componentId undefined | string ComponentId -- must be set to use TimelineComponentEvents Deprecated  
dateFormatOptions undefined | DateFormatOptions Options used to format date string.  
endDate undefined | Date End date: end of the date range of a date-based timeline.  
includeRepeat undefined | boolean Include the repeat option on the Timeline Context Menu.  
initialDuration undefined | number Initial value for the current duration (the location of the thumb) in milliseconds  
isPlaying undefined | boolean Used to control the play/pause state of the Timeline.  
markDate undefined | TimelineDateMarkerProps Display a marker on the timeline rail to indicate current date - will only work if starDate and endDate are defined  
minimized undefined | boolean Show in minimized mode (For future use. Deprecated  
onChange undefined | (duration: number) => void    
onJump undefined | (forward: boolean) => void    
onPlayPause undefined | (playing: boolean) => void    
onSettingsChange undefined | (arg: PlaybackSettings) => void    
repeat undefined | boolean When playing, repeat indefinitely.  
showDuration undefined | boolean Show duration instead of time  
startDate undefined | Date Start date: beginning of the date range of a date-based timeline.  
timeFormatOptions undefined | DateFormatOptions Options used to format time string.  
timeZoneOffset undefined | number Display date and time offset by the number of minutes specified.  
totalDuration number Total duration: range of the timeline in milliseconds.  

Defined in

Last Updated: 05 April, 2024