Tween Class

Beta

A Tween for interpolating values of an object. Instances of this class are owned by a Tweens group.

see The tween.js users guide

Methods

Name Description
constructor(_group: Tweens, _object: any): Tween    
chain(...tweens: Tween[]): this    
delay(amount?: number): this    
duration(d: number): this    
easing(easingFunction?: EasingFunction): this    
end(): this    
getId(): number    
group(group: Tweens): this    
interpolation(interpolationFunction?: InterpolationFunction): this    
onComplete(callback?: TweenCallback): this    
onRepeat(callback: TweenCallback): this    
onStart(callback: TweenCallback): this    
onStop(callback: TweenCallback): this    
onUpdate(callback: UpdateCallback): this    
pause(time: number): this    
repeat(times: number): this    
repeatDelay(amount: number): this    
resume(time?: number): this    
start(time?: string | number): this    
stop(): this    
stopChainedTweens(): void    
to(properties: any, duration?: number): this    
update(time: number): boolean    
yoyo(yoyo: boolean): this    

Properties

Name Type Description
isPaused Accessor ReadOnly boolean    
isPlaying Accessor ReadOnly boolean    

Defined in

Last Updated: 23 April, 2020