Frontstage<SS> Class

Frontstage React component. A Frontstage is a full-screen configuration designed to enable the user to accomplish a task.

Extends

Methods

Name Description
componentDidUpdate(): void    
initializeFrontstageDef(frontstageDef: FrontstageDef, props: FrontstageProps): void Static Initializes a FrontstageDef from FrontstageProps  

Inherited methods

Name Inherited from Description
UNSAFE_componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
UNSAFE_componentWillReceiveProps(nextProps: Readonly<FrontstageProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
UNSAFE_componentWillUpdate(nextProps: Readonly<FrontstageProps>, nextState: Readonly<FrontstageState>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional ComponentLifecycle Catches exceptions generated in descendant components.
componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
componentWillReceiveProps(nextProps: Readonly<FrontstageProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
componentWillUpdate(nextProps: Readonly<FrontstageProps>, nextState: Readonly<FrontstageState>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
forceUpdate(callback?: () => void): void Component<FrontstageProps, FrontstageState>  
getSnapshotBeforeUpdate(prevProps: Readonly<FrontstageProps>, prevState: Readonly<FrontstageState>): SS | null Optional NewLifecycle Runs before React applies the result of render to the document, and
setState<K extends undefined>(state: (prevState: Readonly<FrontstageState>, props: Readonly<FrontstageProps>) => null | S | object | null | S | object, callback?: () => void): void Component<FrontstageProps, FrontstageState>  
shouldComponentUpdate(nextProps: Readonly<FrontstageProps>, nextState: Readonly<FrontstageState>, nextContext: any): boolean Optional ComponentLifecycle Called to determine whether the change in props and state should trigger a re-render.

Inherited properties

Name Type Inherited from Description
context any Component<FrontstageProps, FrontstageState> If using the new style context, re-declare this in your class to be the
contextType Static undefined | Context<any> Component<FrontstageProps, FrontstageState> If set, this.context will be set at runtime to the current value of the given Context.
props undefined Component<FrontstageProps, FrontstageState>  
refs [key: string]: ReactInstance Component<FrontstageProps, FrontstageState>  
state Readonly<FrontstageState> Component<FrontstageProps, FrontstageState>  

Defined in

Last Updated: 05 June, 2020