MeasureVolumeTool Class
Report accumulated volumes of selected elements using the current quantity formatter for volume.
Extends
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): MeasureVolumeTool | ||
getOperation(): MassPropertiesOperation Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> | MeasureElementTool | Used to receive property changes from UI. |
autoLockTarget(): void | MeasureElementTool | Called on data button down event to lock the tool to its current target model. |
beginDynamics(): void | MeasureElementTool | Call to initialize dynamics mode. |
bumpToolSetting(_settingIndex?: number): Promise<boolean> | MeasureElementTool | Used to "bump" the value of a tool setting. |
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | MeasureElementTool | Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled. |
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean | MeasureElementTool | Helper method for responding to a tool setting property value change by updating saved settings. |
endDynamics(): void | MeasureElementTool | Call to terminate dynamics mode. |
exitTool(): Promise<void> | MeasureElementTool | |
getCurrentButtonEvent(ev: BeButtonEvent): void | MeasureElementTool | Fill the supplied button event from the current cursor location. |
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps | MeasureElementTool | Called to allow snapping to pickable decoration geometry. |
getMarkerToolTip(responseProps: MassPropertiesResponseProps): Promise<HTMLElement> Protected | MeasureElementTool | |
getPrompt(): string | MeasureElementTool | Returns the prompt based on the tool's current state. |
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> | MeasureElementTool | Override to return the property that is disabled/enabled if the supplied property is a lock property. |
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> | MeasureElementTool | Invoked before the locate tooltip is displayed to retrieve the information about the located element. |
initLocateElements(enableLocate: booleantrue, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | MeasureElementTool | Helper method for tools that need to locate existing elements. |
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void | MeasureElementTool | Helper method to establish initial values for tool setting properties from saved settings. |
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean | MeasureElementTool | Checks that the adjusted point from the supplied button event is within the project extents for spatial views. |
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | MeasureElementTool | Invoked when the data button is released. |
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void | MeasureElementTool | Called to allow Tool to display dynamic elements. |
onInstall(): Promise<boolean> | MeasureElementTool | Override to execute additional logic when tool is installed. |
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> | MeasureElementTool | Called when any key is pressed or released. |
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | MeasureElementTool | Invoked when the middle mouse button is pressed. |
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | MeasureElementTool | Invoked when the middle mouse button is released. |
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> | MeasureElementTool | Called when Control, Shift, or Alt modifier keys are pressed or released. |
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> | MeasureElementTool | Invoked when the button is released after onMouseStartDrag. |
onMouseMotion(_ev: BeButtonEvent): Promise<void> | MeasureElementTool | Invoked when the cursor is moving |
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> | MeasureElementTool | Invoked when the cursor begins moving while a button is depressed. |
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> | MeasureElementTool | Invoked when the mouse wheel moves. |
onRedoPreviousStep(): Promise<boolean> | MeasureElementTool | Called to reinstate to a previous tool state (ex. |
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | MeasureElementTool | Invoked when the reset button is pressed. |
onSelectedViewportChanged(_previous: Viewport, current: Viewport): Promise<void> | MeasureElementTool | Called when active view changes. |
onSuspend(): Promise<void> | MeasureElementTool | Notification of a ViewTool or InputCollector starting and this tool is being suspended. |
onTouchCancel(_ev: BeTouchEvent): Promise<void> | MeasureElementTool | Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches. |
onTouchComplete(_ev: BeTouchEvent): Promise<void> | MeasureElementTool | Called when the last touch point is removed from the surface completing the current gesture. |
onTouchEnd(_ev: BeTouchEvent): Promise<void> | MeasureElementTool | Called when user removes a touch point by lifting a finger or stylus from the surface. |
onTouchMove(_ev: BeTouchEvent): Promise<void> | MeasureElementTool | Called when a touch point moves along the surface. |
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> | MeasureElementTool | Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap. |
onTouchStart(_ev: BeTouchEvent): Promise<void> | MeasureElementTool | Called when user adds a touch point by placing a finger or stylus on the surface. |
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> | MeasureElementTool | Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving. |
parseAndRun(..._args: string[]): Promise<boolean> | MeasureElementTool | Run this instance of a tool using a series of string arguments. |
reloadToolSettingsProperties(): void | MeasureElementTool | Called by tool to inform UI to reload ToolSettings with new set of properties. |
reportMeasurements(): void Protected | MeasureElementTool | |
run(..._args: any[]): Promise<boolean> | MeasureElementTool | Establish this tool as the active PrimitiveTool. |
saveChanges(): Promise<void> | MeasureElementTool | If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string. |
supplyToolSettingsProperties(): undefined | DialogItem[] | MeasureElementTool | Used to supply list of properties that can be used to generate ToolSettings. |
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void | MeasureElementTool | Called by tool to synchronize the UI with property changes made by tool. |
testDecorationHit(_id: string): boolean | MeasureElementTool | Called to support operations on pickable decorations, like snapping. |
updateTotals(selectionSetResult?: MassPropertiesResponseProps): Promise<void> Protected | MeasureElementTool | |
register(namespace?: string): void Static | MeasureElementTool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
iconSpec Static | string | The icon for this Tool. | |
toolId Static | string | The unique string that identifies this tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
briefcase Accessor ReadOnly | undefined | BriefcaseConnection | MeasureElementTool | Get the briefcase on which this tool operates, if the tool has successfully installed and the target iModel is a briefcase. |
description Accessor ReadOnly | string | MeasureElementTool | Get the localized description string from this Tool's class |
description Accessor Static ReadOnly | string | MeasureElementTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, flyover is returned. |
englishKeyin Accessor Static ReadOnly | string | MeasureElementTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | MeasureElementTool | Get the localized flyover string from this Tool's class |
flyover Accessor Static ReadOnly | string | MeasureElementTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, keyin is returned. |
hidden Static | boolean | MeasureElementTool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | MeasureElementTool | Get the iconSpec from this Tool's class. |
iModel Accessor ReadOnly | IModelConnection | MeasureElementTool | Get the iModel on which this tool operates. |
isControlDown Accessor ReadOnly | boolean | MeasureElementTool | Convenience method to check whether control key is currently down without needing a button event. |
isDynamicsStarted Accessor ReadOnly | boolean | MeasureElementTool | Call to find out if dynamics are currently active. |
keyin Accessor ReadOnly | string | MeasureElementTool | Get the localized keyin string from this Tool's class |
keyin Accessor Static ReadOnly | string | MeasureElementTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
maxArgs Accessor Static ReadOnly | undefined | number | MeasureElementTool | The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum. If subclasses override parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor Static ReadOnly | number | MeasureElementTool | The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static | string | MeasureElementTool | The namespace that provides localized strings for this Tool. |
receivedDownEvent | boolean | MeasureElementTool | Used to avoid sending tools up events for which they did not receive the down event. |
targetIsLocked | boolean | MeasureElementTool | |
targetModelId Accessor | undefined | string | MeasureElementTool | |
targetView | Viewport | undefined | MeasureElementTool | The viewport within which the tool operates. |
toolId Accessor ReadOnly | string | MeasureElementTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.