Development prerequisites

Writing an iTwin.js application requires the following software:

  • Node.js (latest 16.x LTS version)
    • This provides the backend JavaScript runtime.
    • The installation also includes the npm command line tool.

Suggested tools

The following tools are very helpful and highly suggested for working with iTwin.js:

  • Git
    • This is the source code control system for the iTwin.js repositories.
  • Google Chrome
    • This is the preferred tool for developing and debugging frontend JavaScript.
  • Visual Studio Code
    • This is the recommended editor and debugger for iTwin.js applications.
    • VS Code also supplies a graphical user interface for working with Git.
    • The following VS Code extensions can also be quite helpful:
  • TypeScript
    • iTwin.js applications are written in TypeScript and then compiled to plain JavaScript.
  • Node Package Manager (npm)
    • npm is used to install and manage dependencies of an iTwin.js application.
    • The npm command line and npm scripts are used to build and test iTwin.js applications.

Last Updated: 03 February, 2023