AllowedUiItemProviderOverrides Interface

Deprecated  in 3.6. Use AllowedUiItemsProviderOverrides instead.

UiItemProviderOverrides allows the application that registers a provider to limit when it is allowed to provide items

Properties

Name Type Description
providerId undefined | string allows providerId to be overridden in the items manager for cases where the same provider needs to provide different content to different stages  
stageIds undefined | string[] if specified then the current stage's Id will be compared before allowing any items to be provided  
stageUsages undefined | string[] if specified then the current stage's Usage will be compared before allowing any items to be provided  

Defined in

Last Updated: 16 April, 2024