Elements

Subclasses of Elements. See the learning articles.

Classes

Name Description  
AnnotationElement2d 2d element used to annotate drawings and sheets.  
Callout A graphical DetailingSymbol that calls out a reference to another drawing.  
DefinitionContainer A DefinitionContainer exclusively owns a set of DefinitionElements contained within its sub-model (of type DefinitionModel).  
DefinitionElement A Definition Element holds configuration-related information that is meant to be referenced / shared.  
DefinitionGroup A non-exclusive set of DefinitionElements grouped using the DefinitionGroupGroupsDefinitions relationship.  
DefinitionPartition A DefinitionPartition element establishes a Definition modeling perspective for its parent Subject.  
DefinitionSet This abstract class unifies DefinitionGroup and DefinitionContainer for relationship endpoint purposes.  
DetailCallout A graphical Callout that references a detail drawing.  
DetailingSymbol A graphical detailing symbol that is placed on a Drawing or Sheet.  
Document An InformationContentElement that identifies the content of a document.  
DocumentPartition A DocumentPartition element establishes a Document modeling perspective for its parent Subject.  
Drawing A document that represents a drawing, that is, a two-dimensional graphical representation of engineering data.  
DrawingGraphic 2d element used to persist graphics for use in drawings.  
DrawingGraphicRepresentsFunctionalElement Relates a DrawingGraphic to the FunctionalElement that it represents  
DriverBundleElement Element used in conjunction with bis:ElementDrivesElement relationships to bundle multiple inputs before  
Element Elements are the smallest individually identifiable building blocks for modeling the real world in an iModel.  
ElementSubTreeDeleter Performs a breadth-first search to visit elements in top-down order.  
ElementTreeBottomUp Does a depth-first search on the tree defined by an element and its sub-models and children.  
ElementTreeDeleter Deletes an entire element tree, including sub-models and child elements.  
ElementTreeWalkerScope Records the path that a tree search took to reach an element or model.  
ElevationCallout A graphical Callout that references an elevation drawing.  
An information element that links to an embedded file.  
ExternalSource An ExternalSource refers to an 'information container' found in a repository.  
ExternalSourceAttachment Attachment of an ExternalSource  
ExternalSourceGroup A group of ExternalSources that are collectively a source of information for one or more elements.  
FunctionalBreakdownElement A FunctionalBreakdownElement is a folder node in the functional hierarchy.  
FunctionalComponentElement A FunctionalComponentElement is a leaf node in the functional hierarchy.  
FunctionalComposite  
FunctionalElement A FunctionalElement captures functional requirements that will ultimately be fulfilled by a PhysicalElement.  
FunctionalElementIsOfType Relates a FunctionalElement to its FunctionalType  
FunctionalModel A container for persisting FunctionalElements.  
FunctionalPartition A FunctionalPartition element is a key part of the iModel information hierarchy and is always parented  
FunctionalType Defines a set of properties (the 'type') that can be associated with a Functional Element.  
GenericDocument The Generic:Document class is used when a document cannot be further classified.  
GenericGraphicalModel3d A generic container for persisting BisCore:GraphicalElement3d instances.  
GenericGraphicalType2d The Generic:GraphicalType2d class is used when graphical types cannot be further classified.  
GenericPhysicalMaterial The Generic:PhysicalMaterial class is used when the physical material cannot be further classified.  
GenericPhysicalType The Generic:PhysicalType class is used when the physical type cannot be further classified.  
GeometricElement An abstract base class to model real world entities that intrinsically have geometry.  
GeometricElement2d An abstract base class to model information entities that intrinsically have 2d geometry.  
GeometricElement3d An abstract base class to model real world entities that intrinsically have 3d geometry.  
GeometryPart A Definition Element that specifies a collection of geometry that is meant to be reused across Geometric  
Graphic3d The Generic:Graphic3d class is used when 3D graphics cannot be further classified.  
GraphicalElement2d An abstract base class for 2d Geometric Elements that are used to convey information within graphical presentations (like drawings).  
GraphicalElement3d A 3d Graphical Element  
GraphicalPartition3d A GraphicalPartition3d element establishes a 3D Graphical modeling perspective for its parent Subject.  
GraphicalType2d Defines a set of properties (the type) that can be associated with a 2D Graphical Element.  
Group The Generic:Group class is used when the group cannot be further classified.  
GroupInformationElement Group Information is an abstract base class for modeling entities whose main purpose is to reference a group of related elements.  
GroupInformationPartition A GroupInformationPartition element establishes a Group Information modeling perspective for its parent Subject.  
GroupModel A generic container for BisCore:GroupInformationElement instances.  
InformationContentElement Information Content Element is an abstract base class for modeling pure information entities.  
InformationPartitionElement An abstract base class for elements that establishes a particular modeling perspective for its parent Subject.  
InformationRecordElement Information Record Element is an abstract base class for modeling information records.  
InformationRecordPartition An InformationRecordPartition element establishes a Information Record modeling perspective for its parent Subject.  
InformationReferenceElement Information Reference is an abstract base class for modeling entities whose main purpose is to reference something else.  
LineStyle The definition element for a line style  
LinkElement An information element that specifies a link.  
LinkPartition A LinkPartition element establishes a Link modeling perspective for its parent Subject.  
PhysicalElement An Element that is spatially located, has mass, and can be touched.  
PhysicalElementFulfillsFunction Relates a PhysicalElement to the FunctionalElement elements that it fulfills.  
PhysicalMaterial A PhysicalMaterial defines the matter that makes up physical elements.  
PhysicalObject The Generic:PhysicalObject class is used when physical elements cannot be further classified.  
PhysicalPartition A PhysicalPartition element establishes a Physical modeling perspective for its parent Subject.  
PhysicalType Defines a set of properties (the type) that can be associated with a Physical Element.  
PlanCallout A graphical Callout that references a plan drawing.  
RecipeDefinitionElement Defines a recipe for generating instances from a definition.  
RenderMaterialElement Defines a rendering material.  
RenderTimeline Describes how to animate a view of a GeometricModel to show change over time using a RenderSchedule.Script.  
An information element that links to a repository.  
RoleElement A real world entity is modeled as a Role Element when a set of external circumstances define an important  
SectionCallout A graphical Callout that references a section drawing.  
SectionDrawing A document that represents a section drawing, that is, a graphical documentation derived from a planar  
SectionDrawingLocation A SectionDrawingLocation element identifies the location of a SectionDrawing in the context of a SpatialModel,  
Sheet A digital representation of a sheet of paper.  
SheetBorderTemplate The template for a SheetBorder  
SheetTemplate The template for a Sheet  
SpatialElement An Element that occupies real world space.  
SpatialLocation The Generic:SpatialLocation class is used when spatial locations cannot be further classified.  
SpatialLocationElement Identifies a tracked real world location but has no mass and cannot be touched.  
SpatialLocationPartition A SpatialLocationPartition element establishes a SpatialLocation modeling perspective for its parent Subject.  
SpatialLocationType Defines a set of properties (the type) that can be associated with a spatial location.  
Subject A Subject is an information element that describes what this repository (or part thereof) is about.  
Link to the Configuration for an iModel Synchronization Job  
TemplateRecipe2d A recipe that uses a 2D template for creating new instances.  
TemplateRecipe3d A TemplateRecipe3d is a DefinitionElement that has a sub-model that contains the 3d template elements.  
TextAnnotation2d 2D Text Annotation  
TextAnnotation3d 3D Text Annotation  
Texture Defines a rendering texture that is associated with a Material and applied to surface geometry.  
TitleText A graphical DetailingSymbol that contains title text.  
TypeDefinitionElement Defines a set of properties (the type) that may be associated with an element.  
An information element that specifies a URL link.  
ViewAttachmentLabel A graphical DetailingSymbol that contains a view attachment label.  
VolumeElement A Volume Element is a Spatial Location Element that is restricted to defining a volume.  

Global Functions

Name Description  
deleteElementSubTrees Deletes all element sub-trees that are selected by the supplied filter.  
deleteElementTree Deletes an element tree starting with the specified top element.  

Interfaces

Name Description  
ChannelControl Controls which channels of an iModel are permitted for write operations.  
ElementTreeWalkerModelInfo  
OnChildElementArg Argument for the Element.onChildXxx static methods  
OnChildElementIdArg Argument for the Element.onChildXxx static methods that only supply the Id of the child Element.  
OnChildElementPropsArg Argument for the Element.onChildXxx static methods that supply the properties of the child Element to be inserted or updated.  
OnElementArg Argument for the Element.onXxx static methods  
OnElementIdArg Argument for the Element.onXxx static methods that notify of operations to an existing Element supplying its Id, ModelId and FederationGuid.  
OnElementPropsArg Argument for Element.onInsert and Element.onUpdate static methods.  
OnSubModelIdArg Argument for several Element.onSubModelXxx static methods  
OnSubModelPropsArg Argument for the Element.onSubModelInsert static method  
RenderMaterialElementParams Parameters used to create a RenderMaterial element.  
TextureCreateProps A TextureProps in which the image data can be specified either as a base-64-encoded string or a Uint8Array.  

Namespaces

Name Description  
ChannelControl  
RenderMaterialElement  

Type Aliases

Name Description  
ChannelKey The key for a channel.  
ElementSubTreeDeleteFilter  

Last Updated: 03 April, 2024