appui-react

Classes

Name Description
AccuDrawCommandItems AccuDraw Command Items - useful in Keyboard Shortcuts
AccuDrawGrabInputFocusEvent AccuDraw Grab Input Focus event
AccuDrawKeyboardShortcuts Default AccuDraw Keyboard Shortcuts
AccuDrawSetCompassModeEvent AccuDraw Set Compass Mode event
AccuDrawSetFieldFocusEvent AccuDraw Set Field Focus event
AccuDrawSetFieldLockEvent AccuDraw Set Field Lock event
AccuDrawSetFieldValueFromUiEvent AccuDraw Set Field Value from Ui event
AccuDrawSetFieldValueToUiEvent AccuDraw Set Field Value to Ui event
AccuDrawUiSettingsChangedEvent AccuDraw Ui Settings Changed event
AccuDrawWidgetControl AccuDraw Widget Control
ActionButtonItemDef Abstract base class that is used by classes to execute an action when pressed.
ActiveContentChangedEvent Active Content Changed Event class.
ActivityMessageCancelledEvent Activity Message Cancelled Event class.
ActivityMessageUpdatedEvent Activity Message Added Event class.
AnalysisAnimationTimelineDataProvider Analysis Timeline Data Provider - Allows a TimelineComponent to animate the AnalysisStyle information stored in a ViewState.
AppNotificationManager Subclass of NotificationManager in @itwin/core-frontend to be used to initialize IModelApp.
AppUiSettings These are the UI settings that are stored in the Redux store.
BackstageManager Controls backstage.
BaseUiItemsProvider Base implementation of a UiItemsProvider.
CardPopup Popup component for Input Editor
CommandItemDef An Item that executes a Command.
ConfigurableBase The base class for all ConfigurableUi elements
ConfigurableCreateInfo Information for creating a ConfigurableUi element
ConfigurableUiControl The abstract base class for all Frontstage controls.
ContentControl The base class for Frontstage content controls.
ContentControlActivatedEvent ContentControl Activated Event class.
ContentDialogChangedEvent Content Dialog Changed Event class.
ContentDialogRenderer ContentDialogRenderer React component renders modeless dialogs.
ContentGroup ContentGroup class.
ContentGroupProvider Abstract class that can be implemented and specified by frontstage to dynamically construct
ContentLayout Content Layout React component.
ContentLayoutActivatedEvent Content Layout Activated Event class.
ContentLayoutDef Content Layout Definition class.
CoreTools Utility Class that provides definitions of tools provided by the core-frontend core.
CubeNavigationAidControl Navigation Aid that displays an interactive rotation cube for Spatial views that synchronizes with the rotation of the iModel Viewport
CursorInformation Cursor Information class
CursorPopup CursorPopup React component
CursorPopupManager CursorPopup component
CursorPopupRenderer CursorPopupRenderer React component.
CursorUpdatedEvent Cursor Updated Event class.
CustomItemDef An Item that renders a React component.
DialogChangedEvent Dialog Changed Event class.
DrawingNavigationAidControl Navigation Aid that displays an interactive mini-map for Drawing views that synchronizes with the iModel Viewport.
ElementTooltip ElementTooltip React component.
ElementTooltipChangedEvent ElementTooltip Changed Event class.
ExpandableSection Expandable Section React component
FloatingContentControl
FloatingViewportContentControl
FrameworkAccuDraw Subclass of AccuDraw in @itwin/core-frontend to be used to initialize IModelApp.
FrameworkToolAdmin Subclass of ToolAdmin in @itwin/core-frontend to be used to initialize IModelApp.
FrameworkUiAdmin Subclass of UiAdmin in @itwin/core-frontend to be used to initialize IModelApp.
FrontstageActivatedEvent Frontstage Activated Event class.
FrontstageDeactivatedEvent Frontstage Deactivated Event class.
FrontstageDef FrontstageDef class provides an API for a Frontstage.
FrontstageProvider Provides a definition required to create a Frontstage.
FrontstageReadyEvent Frontstage Ready Event class.
GroupItemDef An Item that opens a group of items.
HideIsolateEmphasizeActionHandler Interface for class that handles Hide, Isolate, and Emphasize Actions
HideIsolateEmphasizeManager Provides helper functions for doing commands on logical selection like categories and subjects.
IModelViewportControl iModel Viewport Control
InputEditorCommitHandler
InputFieldMessage InputField message pops up near pointer when attempting an invalid interaction.
InputFieldMessageAddedEvent Input Field Message Added Event class
InputFieldMessageRemovedEvent Input Field Message Removed Event class.
ItemDefBase The base class for Items.
ItemList Contains a list of Items.
ItemMap Contains a map of Items.
KeyboardShortcut Keyboard Shortcut used to execute an action
KeyboardShortcutContainer Keyboard Shortcut Container
KeyboardShortcutMenu React component that displays a context menu at the cursor containing keyboard shortcuts.
KeyboardShortcutMenuEvent KeyboardShortcut Menu Event class.
ListPicker List Picker that lets the user pick from a list of items to enable/disable
ListPickerItem List Picker Item React component
MessageAddedEvent Message Added Event class.
MessageCenterField Message Center Field React component.
MessageManager The MessageManager class manages messages and prompts.
MessagesUpdatedEvent Messages Updated Event class.
ModalDialogChangedEvent Modal Dialog Changed Event class.
ModalDialogRenderer ModalDialogRenderer React component renders modal dialogs
ModalFrontstage ModalFrontstage React component
ModalFrontstageChangedEvent Modal Frontstage Stack Changed Event class.
ModalFrontstageClosedEvent Modal Frontstage Closed Event class.
ModelessDialog Modeless Dialog React component uses the Dialog component with a modal={false} prop.
ModelessDialogChangedEvent Modeless Dialog Changed Event class.
ModelessDialogRenderer ModelessDialogRenderer React component renders modeless dialogs.
MouseDownChangedEvent Mouse Down Changed Event class.
NavigationAidActivatedEvent NavigationAid Activated Event class.
NavigationAidControl The base class for Navigation Aid controls.
NestedFrontstage Nested Frontstage related classes and commands
OpenMessageCenterEvent Open Message Center Event class.
PanelStateChangedEvent Panel state changed event class.
PointerMessage Pointer message pops up near pointer when attempting an invalid interaction.
PointerMessageChangedEvent Pointer Message Changed Event emitted by the PointerMessage component
PopupManager Popup Manager class
PopupRenderer Popup Renderer
PopupsChangedEvent Popups Changed Event class.
PositionPopup Popup component at screen position
PropsHelper A set of helper methods for various props
ReactNotifyMessageDetails Describes a message to be displayed to the user and adds support for React components in messages.
ReducerRegistry Redux Reducer Registry.
RestoreAllFrontstagesTool Immediate tool that will reset the layout of all frontstages to that specified in the stage definition.
RestoreFrontstageLayoutTool Immediate tool that will reset the layout to that specified in the stage definition.
ScheduleAnimationTimelineDataProvider ScheduleAnimation Timeline Data Provider - allows a TimelineComponent to animate the data found in a ScheduleScript in a ViewState.
SelectionContextToolDefinitions Utility Class that provides definitions for tools dependent on current selection.
SettingsModalFrontstage Modal frontstage displaying and editing settings from registered settings providers.
StageContentLayout StageContentLayout class.
StagePanelDef A StagePanelDef represents each Stage Panel within a Frontstage.
StandardContentToolsProvider Provide standard tools for the ContentManipulationWidgetComposer.
StandardContentToolsUiItemsProvider
StandardFrontstageProvider FrontstageProvider that provides an "empty" stage.
StandardMessageBox StandardMessageBox React component displays a standard icon, message text and a standard button set in the lower right.
StandardNavigationToolsProvider Provide standard tools for the ViewNavigationWidgetComposer.
StandardNavigationToolsUiItemsProvider Provide standard tools for the ViewNavigationWidgetComposer.
StandardStatusbarItemsProvider Provide standard statusbar fields for the SimpleStatusbarWidget
StandardStatusbarUiItemsProvider Provide standard statusbar fields for the SimpleStatusbarWidget
StateManager Centralized state management class using Redux actions, reducers and store.
StatusBar Status Bar React component.
StatusBarWidgetComposerControl StatusBarWidgetComposerControl provides status bar to specified StatusBarWidgetComposerControl.Frontstage that allows status bar items to be populated
StatusBarWidgetControl Status Bar Widget Control.
SyncToolSettingsPropertiesEvent Sync Tool Settings Properties Event class.
SyncUiEventDispatcher This class is used to send eventIds to interested UI components so the component can determine if it needs
TileLoadingIndicator TileLoadingIndicator React component
ToolActivatedEvent Tool Activated Event class.
ToolAssistanceChangedEvent Tool Assistance Changed event class
ToolAssistanceField Tool Assistance Field React component.
ToolbarButtonHelper A set of Dom helper methods
ToolbarHelper Helper functions for defining a Toolbar items used in Toolbar, ToolbarComposer and UiItemsProvider.
ToolbarPopup Popup component for Toolbar
ToolIconChangedEvent Tool Icon Changed Event class.
ToolInformation Provides information about a tool with a given id, including the ToolUiProvider.
ToolItemDef An Item that starts the execution of a Tool.
ToolSettingsPopup Popup component for Tool Settings
ToolUiProvider ToolUiProvider provides the Tool Settings and/or Tool Assistance UI for a tool.
UiFramework Main entry point to configure and interact with the features provided by the AppUi-react package.
UiItemsManager Controls registering of UiItemsProviders and calls the provider's methods when populating different parts of the User Interface.
UiSyncEvent UiSync Event class.
UiVisibilityChangedEvent UiVisibility Event class.
ViewAttributesStatusField Widget for showing Checkboxes for View Attributes
ViewportContentControl The base class for frontstage Viewport content controls that connects to a ScreenViewport
ViewSelector View Selector React component
ViewSelectorChangedEvent ViewSelector Changed Event class.
ViewStateHelper SavedView class.
ViewUtilities Various View utility methods
WidgetControl The base class for Widget controls.
WidgetDef A Widget Definition in the 9-Zone Layout system.
WidgetHost A WidgetHost represents a definition that hosts one or most Widgets in a Frontstage.
WidgetManager Widget Manager class.
WidgetStateChangedEvent Widget State Changed Event class.

Constants

Name Description
ConditionalBooleanValue
ConditionalStringValue
ConfigurableUiActions An object with a function that creates each ConfigurableUiReducer that can be handled by our reducer.
ReducerRegistryInstance ReducerRegistryInstance singleton instance of Reducer Registry
SafeAreaContext Context used to manage safe area (feature used by devices with non-rectangular screens).
SessionStateActions An object with a function that creates each SessionStateReducer that can be handled by our reducer.
sessionStateMapDispatchToProps Object that contains available actions that modify SessionState.
SYSTEM_PREFERRED_COLOR_THEME System preferred color theme.
TOOLBAR_OPACITY_DEFAULT The default widget opacity.
ToolbarDragInteractionContext Context used to enable toolbar drag interaction.
WIDGET_OPACITY_DEFAULT The default widget opacity.

Enumerations

Name Description
ColorTheme Enum for the Color Theme string.
ConfigurableUiActionId Action Ids used by Redux and to send sync UI components.
ConfigurableUiControlType The type of the ConfigurableUiControl.
CursorDirection Enum for Cursor Direction
CursorDirectionParts Enum for Cursor Direction parts
HideIsolateEmphasizeAction Supported Hide, Isolate, and Emphasize Actions.
KeyinFieldLocalization Controls whether localized and/or non-localized key-in strings appear in a KeyinField's auto-completion list.
ListItemType Enum for the list picker item type
SafeAreaInsets Describes available safe area insets.
SelectionScope Selection Scope enum.
SessionStateActionId Action Ids used by Redux and to send sync UI components.
StagePanelLocation Available Stage Panel locations.
StagePanelSection Enum for Stage Panel Sections
StagePanelState Enum for StagePanel state.
StageUsage Standard stage uses.
StatusBarLabelSide Defines which side of Icon where label is placed
StatusBarSection Status bar Groups/Sections from Left to Right
SyncUiEventId Event Id used to sync UI components.
ToolbarOrientation Used to specify the orientation of the toolbar.
ToolbarUsage Used to specify the usage of the toolbar which determine the toolbar position.
WidgetState Widget state enum.
WidgetType Widget type enum.

Global Functions

Name Description
AccuDrawDialog Dialog displays AccuDrawFieldContainer for AccuDraw Ui
AccuDrawFieldContainer AccuDraw Ui Field Container displays AccuDrawInputField for each field
AccuDrawInputField Input field for AccuDraw UI.
AccuDrawWidget AccuDraw Widget displays AccuDrawFieldContainer for AccuDraw Ui
ActivityCenterField Activity Center Field React component.
areNoFeatureOverridesActive return ConditionalBooleanValue object used to show items if selection set is active.
BackstageAppButton BackstageAppButton used to toggle display of Backstage and is shown in the corner of the ToolWidget.
BackstageComposer Backstage component composed from UiFramework.backstage items.
BasicNavigationWidget Basic Navigation Widget that provides standard tools to manipulate views containing element data.
BasicToolWidget Default Tool Widget for standard "review" applications.
Card Card component
combineReducers Turns an object whose values are different reducer functions, into a single
ConfigurableUiContent The ConfigurableUiContent component is the component the pages specified using ConfigurableUi
ConfigurableUiReducer Handles actions to update ConfigurableUiState.
connectIModelConnection Function that will connect a component to the IModelConnection data in the Redux store.
connectIModelConnectionAndViewState Function that will connect a component to the IModelConnection data in the Redux store
ContentDialog Content Dialog React component uses the Dialog component with a modal={false} prop.
ContentToolWidgetComposer ContentToolWidgetComposer composes a Tool Widget with no tools defined by default.
createAction Creates a basic Redux Redux Action with a payload value.
CursorPopupContent CursorPopup content with padding
DefaultDialogGridContainer DefaultDialogGridContainer populates a React node with the items specified by the UiLayoutDataProvider
DefaultViewOverlay Default viewport overlay that examines ViewState of the active view for a schedule script, analysis data, or solar data.
featureOverridesActiveStateFunc return state with isVisible set to true is SectionSet is active.
FloatingViewportContent
FrameworkReducer Framework reducer that combines the ConfigurableUiReducer and SessionStateReducer.
getFeatureOverrideSyncEventIds return SyncEventIds that trigger selection state function refresh.
getIsHiddenIfFeatureOverridesActive return ConditionalBooleanValue object used to show item if feature overrides are active.
getIsHiddenIfSelectionNotActive return ConditionalBooleanValue object used to show items if selection set is active.
getListPanel
getQuantityFormatsSettingsManagerEntry Return a SettingsTabEntry that can be used to define the available settings that can be set for an application.
getSelectionContextSyncEventIds return SyncEventIds that trigger selection state function refresh.
getUiSettingsManagerEntry Return a SettingsTabEntry that can be used to define the available settings that can be set for an application.
IModelConnectedViewport Viewport that is connected to the IModelConnection property in the Redux store.
IModelConnectedViewSelector ViewSelector that is connected to the IModelConnection property in the Redux store.
isBackstageActionItem BackstageActionItem type guard.
isBackstageStageLauncher BackstageStageLauncher type guard.
isNoSelectionActive return SyncEventIds that trigger selection state function refresh.
isStatusBarActionItem StatusBarActionItem type guard.
isStatusBarCustomItem StatusBarCustomItem type guard.
isStatusBarLabelItem StatusBarLabelItem type guard.
isToolbarActionItem ToolbarActionItem type guard.
isToolbarCustomItem ToolbarCustomItem type guard.
isToolbarGroupItem ToolbarGroupItem type guard.
KeyinPalettePopup Keyin Palette Popup Component
NavigationAidHost NavigationAidHost is a component that hosts a NavigationAid that is specific to the active content control.
NavigationWidgetComposer Component that Composes a NavigationWidget typically using toolbars generated via ToolbarComposer class.
PositionPopupContent PositionPopup content with padding
PreviewFeaturesProvider Set which preview features are enabled.
QuantityFormatSettingsPage UI Component shown in settings page to set the active Presentation Unit System and to set format overrides.
SectionsStatusField Status Field for showing section extra tools for clearing and showing manipulators
selectionContextStateFunc return state with isVisible set to true is SectionSet is active.
SelectionCountField Status field component used to display the number of selected items.
SelectionInfoField SelectionInfo Status Field React component.
SelectionScopeField SelectionScopeField React component.
SessionStateReducer Handles actions to update SessionState.
SnapModeField Snap Mode Field React component.
SplitPane Local TypeScript implementation of SplitPane from react-split-pane package since that
StatusBarCenterSection StatusBar Center Section React functional component
StatusBarComposer Component to load components into the StatusBar.
StatusBarDialog Dialog component used in a StatusBarIndicator component.
StatusBarDialogTitleBar Dialog component used in a StatusBarDialog component.
StatusBarDialogTitleBarButton Dialog component used in a StatusBarDialog component.
StatusBarField Field component used in StatusBar component.
StatusBarIndicator General-purpose StatusBar indicator.
StatusBarLabelIndicator StatusBar indicator that shows a label with an icon.
StatusBarLeftSection StatusBar Left Section React functional component
StatusBarPopup Popup component used in StatusBar component.
StatusBarRightSection StatusBar Right Section React functional component
StatusBarSeparator Component used to separate status fields in a status bar.
StatusBarSpaceBetween StatusBar With Space Between Items React functional component
ThemeManager ThemeManager handles setting color themes and element opacity management.
Toolbar Component that displays toolbar items.
ToolbarComposer Toolbar that is populated and maintained by UI item providers.
ToolbarWithOverflow Component that displays toolbar items, displaying only the elements that can fit in the available space,
ToolSettingsGridContainer Component to provide grid of property editors
ToolWidgetComposer ToolWidget component that supports use of ToolbarComposer-based Toolbars.
UiDataProvidedDialog Component to show dialog populated from properties supplied via uiDataProvider
UiSettingsPage UiSettingsPage displaying the active UI settings.
UiStateStorageHandler Allows to provide a custom UiStateStorageHandler.UiStateStorage implementation to persist UI settings
useActiveFrontstageDef Hook to return the active Frontstage def.
useActiveFrontstageId Hook that returns active frontstage id.
useActiveIModelConnection React hook that maintains the active IModelConnection.
useActiveStageId React hook that maintains the active stage Id.
useActiveViewport React hook that maintains the active viewport.
useAnalysisAnimationDataProvider Hook that returns either a AnalysisAnimationTimelineDataProvider or undefined based on if the supplied viewport contains analysis data.
useBackstageManager Hook that returns backstage manager.
useDefaultStatusBarItems Hook that returns items from StatusBarItemsManager.
useDefaultToolbarItems Hook that returns items from ToolbarItemsManager. Deprecated
useIsBackstageOpen Hook that returns isOpen flag of the backstage.
useScheduleAnimationDataProvider Hook that returns either a ScheduleAnimationTimelineDataProvider or undefined based on if the supplied viewport contains schedule script.
useSelectionSetSize React hook that returns element count of a selection set.
useSolarDataProvider Hook that returns either a SolarTimelineDataProvider or undefined based on if the supplied viewport's display style is set to display shadows.
useSpecificWidgetDef Hook that returns the widgetDef for a specific widgetId within the active frontstage.
useTransientState Hook that allows to save and restore transient DOM state (i.e.
useUiItemsProviderBackstageItems Hook that returns items from BackstageItemsManager.
useUiItemsProviderStatusBarItems Hook that returns items from StatusBarItemsManager.
useUiItemsProviderToolbarItems Hook that retrieves active frontstage toolbar items from UiItemsProviders and manage them through ToolbarItemsManager. Deprecated
useUiStateStorageHandler
ViewToolWidgetComposer ViewToolWidgetComposer composes a Navigation Widget with no tools defined by default.

Interfaces

Name Description
AccuDrawDialogProps Properties for AccuDrawDialog
AccuDrawFieldContainerProps Properties for AccuDrawFieldContainer component
AccuDrawInputFieldProps Properties for AccuDrawInputField component
AccuDrawSetCompassModeEventArgs Arguments for AccuDrawSetCompassModeEvent
AccuDrawSetFieldFocusEventArgs Arguments for AccuDrawSetFieldFocusEvent
AccuDrawSetFieldLockEventArgs Arguments for AccuDrawSetFieldLockEvent
AccuDrawSetFieldValueFromUiEventArgs Arguments for AccuDrawSetFieldValueFromUiEvent
AccuDrawSetFieldValueToUiEventArgs Arguments for AccuDrawSetFieldValueToUiEvent
AccuDrawUiSettings AccuDraw User Interface Settings
Action A basic Redux Action.
ActionWithPayload A Redux Action, with additional "payload" information.
ActiveContentChangedEventArgs ActiveContentChangedEvent Args interface.
ActivityMessageEventArgs Activity Message Event arguments.
AllowedUiItemsProviderOverrides UiItemsProvider overrides allows the application that registers a provider to limit when it is allowed to provide items
BackstageActionItem Describes the data needed to insert an action button into the backstage menu.
BackstageAppButtonProps Properties for the BackstageAppButton React component
BackstageComposerProps Props of BackstageComposer component.
BackstageStageLauncher Describes the data needed to insert an action button into the backstage menu.
BackstageToggledArgs Arguments of Backstage.onToggled.
BaseItemState Base state for any 'stateful' React component
BasicNavigationWidgetProps Properties that can be used to append items to the default set of toolbar items.
BasicToolWidgetProps Properties that can be used to append items to the default set of toolbar items.
CanFloatWidgetOptions Describes options of a floating widget.
CardProps Props defining a Card component
ChildWindowLocationProps
CommandHandler Definition for a command handler.
CommandItemProps Properties for a Command item.
CommonBackstageItem Describes the data needed to insert a button into the backstage menu.
CommonStatusBarItem Describes the data needed to insert a button into the status bar.
CommonToolbarItem Describes the data needed to insert a UI items into an existing set of UI items.
ConfigurableUiContentProps Properties for ConfigurableUiContent
ConfigurableUiElement Interface for a ConfigurableUi element
ConfigurableUiState The portion of state managed by the ConfigurableUiReducer.
ContentControlActivatedEventArgs ControlControl Activated Event Args interface.
ContentDialogInfo
ContentDialogProps Properties for the ContentDialog component
ContentGroupProps Properties for a ContentGroup
ContentLayoutActivatedEventArgs Content Layout Activated Event Args class.
ContentLayoutComponentProps Properties for the ContentLayout React component.
ContentProps Properties for content displayed in a content view
ContentToolWidgetComposerProps Props for ContentToolWidgetComposer.
CursorMenuData Definition of data added to Redux store to define cursor menu. Deprecated
CursorMenuItemProps Properties for context menu items.
CursorMenuPayload Definition of data added to Redux store to define cursor menu.
CursorPopupOptions Options for the CursorPopupManager open method
CursorUpdatedEventArgs Cursor Updated Event Args interface.
CustomItemProps Definition for a Custom item that renders a React component.
DeepReadonlyArray TypeScript doesn't actually allow recursive type aliases, so these are just sort of a hack to make DeepReadonly work
DefaultContentTools Defines what tools to include from the provider.
DefaultContentToolsAppData Defines options that may be set in frontstage app data to control what group priorities
DefaultNavigationTools Defines what tools to include from the provider.
DefaultStatusbarItems Defines what items to include from the provider.
DialogChangedEventArgs Dialog Stack Changed Event Args class.
DialogInfo Information maintained by a Dialog Manager about a dialog
ElementTooltipChangedEventArgs ElementTooltipChangedEvent arguments.
EmphasizeElementsChangedArgs Selection Context Action Event Argument
ExpandableSectionProps Properties for the ExpandableSection component
ExtensibleToolbarProps Properties for the ToolbarComposer React components
FloatingViewportContentProps
FrameworkBackstage UiFramework.backstage interface.
FrameworkChildWindows UiFramework.childWindows interface.
FrameworkContent UiFramework.content interface
FrameworkControls UiFramework.controls interface
FrameworkDialog Manages dialog access
FrameworkDialogs UiFramework.dialogs interface.
FrameworkFrontstages UiFramework.frontstages interface
FrameworkKeyboardShortcut Keyboard Shortcut used to execute an action
FrameworkKeyboardShortcutContainer Keyboard Shortcut Container
FrameworkKeyboardShortcuts UiFramework.keyboardShortcuts interface
FrameworkRootState Generic 'root' state for the appui-react package.
FrameworkStackedDialog FrameworkDialog that manages the top most content.
FrameworkState Interface combining all the Framework state interfaces.
FrameworkToolSettings UiFramework.toolSettings interface
FrameworkVisibility UiFramework.visibility interface
FrontstageActivatedEventArgs Frontstage Activated Event Args interface.
FrontstageConfig Configuration from which a frontstage is created.
FrontstageDeactivatedEventArgs Frontstage Deactivated Event Args interface.
FrontstageReadyEventArgs Frontstage Ready Event Args interface.
GroupItemProps Definition for a Group item that opens a group of items.
IModelViewportControlOptions IModelViewportControl options.
InitialAppUiSettings Default values that may be specified for AppUiSettings.
InputEditorPopupProps Props for popup editor
InputFieldMessageEventArgs Input Field Message Event arguments.
ItemProps Definition that specifies properties shared between many ConfigurableUi components.
KeyboardShortcutMenuState State for a KeyboardShortcutMenuEvent and KeyboardShortcutMenu component
KeyboardShortcutProps Properties for a Keyboard Shortcut
KeyinEntry Defines a keyin entry to show/filter in UI
KeyinPalettePopupProps Props defining KeyinPalettePopup component
ListItem List picker item
ListPickerItemProps Properties for the ListPickerItem component
ListPickerProps Properties for the ListPicker component
ListPickerPropsExtended Properties for the ListPicker component
MessageAddedEventArgs MessageAddedEvent arguments.
ModalFrontstageChangedEventArgs Modal Frontstage Changed Event Args interface.
ModalFrontstageClosedEventArgs Modal Frontstage Closed Event Args interface.
ModalFrontstageInfo Modal Frontstage information interface.
ModalFrontstageProps Properties for the ModalFrontstage React component
ModelessDialogInfo
ModelessDialogProps Properties for the ModelessDialog component
MouseDownChangedEventArgs MouseDownChangedEvent Args interface.
NameToReducerMap NameToReducerMap used by Reducer Registry
NavigationAidActivatedEventArgs NavigationAid Activated Event Args interface.
NavigationAidHostProps Properties for the NavigationAidHost React component
NavigationWidgetComposerProps Properties for the NavigationWidgetComposer React components
OpenChildWindowInfo
OverflowToolbarOptions Properties of Toolbar.enableOverflow component.
PanelPinnedChangedEventArgs Panel pinned changed event args interface.
PanelStateChangedEventArgs Panel state changed event args interface.
PointerMessageChangedEventArgs PointerMessageChangedEvent arguments.
PointerMessageProps Properties of PointerMessage component.
PopupInfo Information maintained by PopupManager about a Popup
PopupPropsBase Props for each popup managed by the PopupManager
PopupsChangedEventArgs
PositionPopupProps Props for popup at screen position
PresentationSelectionScope PresentationSelectionScope holds the id and the localized label for a selection scope supported for a specific iModel.
PreviewFeatures List of preview features that can be enabled/disabled.
PreviewFeaturesProviderProps Props for PreviewFeaturesProvider.
QuantityFormatterSettingsOptions Options to initialize the settings page that allows users to set Quantity formatting overrides.
ReactContent Describes React based content
SectionsStatusFieldProps Sections Status Field Props
SelectionCountFieldProps Properties for the SelectionCountField component.
SessionState The portion of state managed by the SessionStateReducer.
SessionStateActionsProps An interface that allows redux connected object to dispatch changes to the SessionState reducer.
SplitPaneProps Props for SplitPane component
StageContentLayoutProps StageContentLayoutProps interface for sharing view layout information.
StagePanelConfig Configuration from which a stage panel is created.
StagePanelSectionsConfig Configuration from which stage panel sections are created.
StandardFrontstageProps Props for StandardFrontstageProvider
StandardMessageBoxProps Properties for StandardMessageBox React component
StatusBarActionItem Describes the data needed to insert an action item into the status bar.
StatusBarComposerProps Properties for the StatusBarComposer React components
StatusBarCustomItem Describes the data needed to insert an item into the StatusBar.
StatusBarDialogProps Properties of StatusBarDialog component.
StatusBarDialogTitleBarButtonProps Properties of StatusBarDialogTitleBarButton component.
StatusBarDialogTitleBarProps Properties of StatusBarDialogTitleBar component.
StatusBarFieldProps Properties of StatusBarField component.
StatusBarIndicatorProps Properties of StatusBarIndicator component.
StatusBarLabelIndicatorProps Properties of StatusBarLabelIndicator component.
StatusBarLabelItem Describes the data needed to insert a label item with an optional icon into the status bar.
StatusBarProps Properties for the StatusBar React component
SupportsViewSelectorChange Interface to be implemented when the ContentControl supports ViewSelector changes
SyncToolSettingsPropertiesEventArgs Sync Tool Settings Properties Event Args interface.
ToolActivatedEventArgs Tool Activated Event Args interface.
ToolAssistanceChangedEventArgs Tool Assistance Changed event arguments.
ToolAssistanceFieldProps Properties of ToolAssistanceField component.
ToolbarActionItem Describes the data needed to insert an action button into a toolbar.
ToolbarCustomItem Describes the data needed to insert a custom button into a toolbar.
ToolbarGroupItem Describes the data needed to insert a group button into a toolbar.
ToolbarProps Properties of Toolbar component.
ToolbarWithOverflowProps Component that displays toolbar items.
ToolIconChangedEventArgs Tool Icon Changed Event Args interface.
ToolItemProps Properties for a Tool item with a tool id.
ToolSettingsEntry Defines a ToolSettings property entry.
ToolSettingsPopupProps Props for defining a popup tool settings component
ToolWidgetComposerProps Properties for the ToolbarComposer React components
UiDataProvidedDialogProps Props for UiDataProvidedDialog component.
UiItemsProvider Describes interface of objects that want to provide UI component to the running IModelApp.
UiItemsProviderRegisteredEventArgs UiItemsProvider register event args.
UiSettingsProviderProps Properties for the UiStateStorageHandler component.
UiSyncEventArgs UiSync Event arguments.
UiVisibilityEventArgs UiVisibility Event Args interface.
UnitSystemSelectorProps Props for UnitSystemSelector
UserSettingsProvider Interface to be implemented but any classes that wants to load their user settings when the UiStateEntry storage class is set.
UseSelectionSetSizeArgs Arguments for useSelectionSetSize hook.
ViewLayout ViewLayout interface for sharing view layout information.
ViewOverlayProps Props of Viewport Overlay Control that show timelines
ViewSelectorChangedEventArgs ViewSelectorChangedEvent Args interface.
ViewSelectorProps Properties for the ViewSelector component
ViewStateHelperProps SavedViewProps interface for sharing ViewState and EmphasizeElements information.
ViewToolWidgetComposerProps Props for ViewToolWidgetComposer.
Widget Describes the data needed to provide a widget.
WidgetConfig Configuration from which a widget is created.
WidgetStateChangedEventArgs Widget State Changed Event Args interface.

Namespaces

Name Description
BackstageItemUtilities Utilities for creating and maintaining backstage items
StatusBar Components used in a StatusBar.
StatusBarDialog Components used in a StatusBarDialog.
StatusBarItemUtilities Utility functions for creating and maintaining StatusBar items.
ToolbarItemUtilities Helper class to create toolbar items.
ToolGroup

Type Aliases

Name Description
ActionCreatorsObject Just an object where every property is a Redux Action Creator.
ActionsUnion A TypeScript type alias that represents the Union Type of all actions
ActionTypes A TypeScript type alias that uses conditional types (read: magic)
AnyItemDef Union of all Item definitions that can be specified in a GroupItem
AnyToolbarItemDef Union of all Item definitions that can be specified in a Toolbar
BackstageItem Describes the data needed to insert a button into the backstage menu.
CardPopupProps Props for defining a CardPopup editor
CombinedReducerState A type alias which represents the state created by the reducer returned by combineReducers for a given reducers argument.
CombineReducersFunction
ConditionalBooleanValue Class used to return a boolean value.
ConditionalStringValue Class used to return a string value.
ConfigurableUiActionsUnion Union of ConfigurableUi Redux actions
ConfigurableUiControlConstructor
ContentCallback
CursorPopupProps Properties for the CursorPopup React component
DeepReadonly Similar to the built-in Readonly, type alias but applied recursively.
DeepReadonlyObject TypeScript doesn't actually allow recursive type aliases, so these are just sort of a hack to make DeepReadonly work
FunctionType
MenuItemProps Menu Item Properties Deprecated
NotifyMessageDetailsType Types for NotifyMessageDetails.
NotifyMessageType Types for message in MessageManager
Placement Identifies the placement of a given element.
PopupContentType Type for Popup Content
ProviderItem Properties of an item provided by UiItemsProvider.
Reducer
ReducerActions A TypeScript type alias that represents a union of all action types handled by a Redux Reducer.
ReducerMapActions A type alias which represents the union type of all actions handled by the reducer returned by combineReducers for a given reducers argument.
SessionStateActionsUnion Union of SessionState Redux actions
StagePanelMaxSizeSpec Available units of panel max size. Deprecated
StagePanelSectionConfig Configuration from which a stage panel section is created.
StagePanelSizeSpec Available units of panel size - pixels or percentage of app size.
StateType A TypeScript type alias that represents the return type of a Redux Reducer.
StatusBarFieldId Status Bar Field type.
StatusBarItem Describes the data needed to insert a button into the status bar.
ThemeId Describe valid themes.
ToolbarItem Any Button Type that can be inserted into a toolbar.
ToolbarPopupProps Props for a popup toolbar
UiItemsProviderOverrides Allowed overrides applied to a UiItemsProvider the application that registers a provider to limit when it is allowed to provide items.
ViewSelectorDefaultProps Default properties of ViewSelector component.
WidgetPanelProps Properties of a WidgetPanelProps component

Last Updated: 05 April, 2024