BackstageActionItem Interface

Describes the data needed to insert an action button into the backstage menu.

Extends

Properties

Name Type Description
execute Readonly () => void    

Inherited properties

Name Type Inherited from Description
badge Readonly undefined | BadgeType CommonBackstageItem Describes badge.
groupPriority Readonly number CommonBackstageItem Specifies the item's grouping value.
icon Readonly undefined | IconSpec CommonBackstageItem Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id.
id Readonly string CommonBackstageItem Required unique id of the item.
isActive Readonly boolean | ConditionalBooleanValue CommonBackstageItem Describes if the item is active.
isDisabled Readonly boolean | ConditionalBooleanValue CommonBackstageItem Describes if the item is enabled or disabled.
isHidden Readonly boolean | ConditionalBooleanValue CommonBackstageItem Describes if the item is visible or hidden.
itemPriority Readonly number CommonBackstageItem Priority within a group (recommend using values 1 through 100).
label Readonly string | ConditionalStringValue CommonBackstageItem Label.
subtitle Readonly string | ConditionalStringValue CommonBackstageItem Subtitle.
tooltip Readonly string | ConditionalStringValue CommonBackstageItem Tooltip.

Defined in

Last Updated: 05 April, 2024