CursorPopupProps Interface
Properties for the CursorPopup React component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
content | ReactNode | ||
id | string | ||
offset | Readonly<WritableXAndY> | ||
onSizeKnown | undefined | (size: SizeProps) => void | ||
pt | Readonly<WritableXAndY> | ||
relativePosition | RelativePosition | ||
shadow | undefined | boolean | ||
title | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | CommonProps | Custom CSS class name |
itemId | undefined | string | CommonProps | Optional unique identifier for item. |
style | undefined | CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 01 December, 2023