ModalFrontstageProps Interface

Properties for the ModalFrontstage React component

Extends

Properties

Name Type Description
appBarRight undefined | ReactNode An optional React node displayed in the upper right of the modal Frontstage.  
children undefined | ReactNode Content  
closeModal () => any    
isOpen undefined | boolean Indicates whether the modal Frontstage is open  
navigateBack undefined | () => any    
title string Title displayed at the top of the modal Frontstage  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 05 April, 2024