StandardFrontstageProvider Class

FrontstageProvider that provides an "empty" stage. All tool buttons, statusbar items, and widgets must be provided by one or more item providers, see UiItemsProvider.

Extends

Methods

Name Description
constructor(props: StandardFrontstageProps): StandardFrontstageProvider    
frontstageConfig(): FrontstageConfig Return the frontstage configuration.  

Properties

Name Type Description
id Accessor ReadOnly string Get the FrontstageProvider id.  

Defined in

Last Updated: 21 March, 2024