ToolAssistanceFieldProps Interface

Properties of ToolAssistanceField component.

Extends

Properties

Name Type Description
cursorPromptTimeout number Cursor Prompt Timeout period.  
defaultPromptAtCursor boolean Indicates whether to show promptAtCursor by default.  
fadeOutCursorPrompt boolean Fade Out the Cursor Prompt when closed.  
includePromptAtCursor boolean Indicates whether to include promptAtCursor Checkbox.  
uiStateStorage undefined | UiStateStorage Optional parameter for persistent UI settings.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 21 March, 2024