ToolSettingsPopupProps Interface

Props for defining a popup tool settings component

Extends

Properties

Name Type Description
dataProvider DialogLayoutDataProvider    
onCancel OnCancelFunc    
orientation Orientation    
relativePosition RelativePosition    

Inherited properties

Name Type Inherited from Description
el HTMLElement PopupPropsBase  
id string PopupPropsBase  
offset Readonly<WritableXAndY> PopupPropsBase  
pt Readonly<WritableXAndY> PopupPropsBase  

Defined in

Last Updated: 05 April, 2024