register MethodStatic

static function to register the StandardContentToolsProvider

register(providerId: string, defaultNavigationTools?: DefaultNavigationTools, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardNavigationToolsProvider

Parameter Type Description
providerId string unique identifier for this instance of the provider. This is required in case separate packages want
to set up custom stage with their own subset of standard tools
defaultNavigationTools DefaultNavigationTools if undefined all available tools are provided to stage. If defined only those
specific tool buttons are shown.
isSupportedStage (stageId: string, stageUsage: string, stageAppData?: any) => boolean optional function that will be called to determine if tools should be added to current stage. If not set and
the current stage's usage is set to StageUsage.General then the provider will add items to frontstage.

Returns - StandardNavigationToolsProvider

Defined in

Last Updated: 05 April, 2024