connectIModelConnectionAndViewState Function

Function that will connect a component to the IModelConnection data in the Redux store

connectIModelConnectionAndViewState(mapStateToProps?: any, mapDispatchToProps?: any): InferableComponentEnhancerWithProps<any, any>

@example

// connect component for both getting and setting ImodelConnection data from Redux store.
 import { connectIModelConnection, sessionStateMapDispatchToProps, SessionStateActionsProps } from "@itwin/appui-react";

 export interface ComponentProps extends SessionStateActionsProps {
   myData: string;
 }

 export const ConnectControl = connectIModelConnection(null, sessionStateMapDispatchToProps)(ComponentClass);

 //  this then allows connected control to update the store using a call like shown below.
 this.props.setNumItemsSelected(30);
Parameter Type Description
mapStateToProps any optional user function that, if defined, will be executed to provide additional properties from store.
mapDispatchToProps any data passed to Redux connect function.

Returns - InferableComponentEnhancerWithProps<any, any>

Defined in

Last Updated: 05 April, 2024