SyncUiEventId Enumeration

Event Id used to sync UI components. Used to refresh visibility or enable state of control.

Members

Name Value Description
AccuDrawCompassModeChanged AccuDraw compass mode has changed.
AccuDrawRotationChanged AccuDraw rotation has changed.
ActiveContentChanged The active content as maintained by the ContentViewManager has changed.
ActiveViewportChanged The active view maintained by the ViewManager has changed.
BackstageEvent Backstage has been toggled.
ContentControlActivated A Content Control maintained by UiFramework.frontstages has been activated.
ContentLayoutActivated A Content Layout has been activated.
FeatureOverridesChanged The list of feature overrides applied has been changed
FrontstageActivating A Frontstage is activating.
FrontstageReady A Frontstage has been activated and the content has been assigned.
ModalDialogChanged A Modal Dialog has been opened or closed.
ModalFrontstageChanged A Modal Frontstage has been opened or closed.
NavigationAidActivated A NavigationAid has been activated.
SelectionSetChanged The SelectionSet for the active IModelConnection has changed.
SettingsProvidersChanged The list of settings providers registered with SettingsManager has changed.
ShowHideManagerSettingChange  
ToolActivated An InteractiveTool has been activated via the ToolAdmin.
UiStateStorageChanged The current object the reads and write UI State has changed.
ViewedModelsChanged  
ViewStateChanged The current view state has changed (used by view undo/redo toolbar buttons).
WidgetStateChanged The state of a Widget has changed.

Defined in

Last Updated: 05 April, 2024