UiItemsProvider Interface

Describes interface of objects that want to provide UI component to the running IModelApp.

Implemented by

Properties

Name Type Description
getBackstageItems Readonly () => | undefined Provides backstage items.  
getStatusBarItems Readonly () => | undefined Provides status bar items.  
getToolbarItems Readonly () => | undefined Provides toolbar items.  
getWidgets Readonly () => | undefined Provides widgets.  
id Readonly string Id of provider.  
onUnregister Readonly () => void | undefined Function called when the provider is unregistered.  
provideBackstageItems Readonly () => | undefined Provides backstage items. Deprecated  
provideStatusBarItems Readonly (stageId: string, stageUsage: string) => | undefined Provides status bar items. Deprecated  
provideToolbarItems Readonly (stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation) => | undefined Provides toolbar items. Deprecated  
provideWidgets Readonly (stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection) => | undefined Provides widgets. Deprecated  

Defined in

Last Updated: 15 July, 2024