ParsedInputProps Interface

Props for ParsedInput control

Extends

Properties

Name Type Description
formatValue (value: number) => string    
initialValue number InitialValue which is used to restore input field if ESC is pressed  
onChange undefined | (newValue: number) => void    
parseString (stringValue: string) => ParseResults    
readonly undefined | boolean if readonly then only the formatValue function is used.  
ref undefined | Ref<HTMLInputElement> Provides ability to return reference to HTMLInputElement  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 05 April, 2024