collectReferenceIds MethodProtected

Collect the Ids of this entity's references at this level of the class hierarchy. A reference is any entity referenced by this entity's EC Data, including json fields. This is important for cloning operations but can be useful in other situations as well.

collectReferenceIds(referenceIds: EntityReferenceSet): void

@note This should be overridden (with super called) at each level the class hierarchy that introduces references.

@see Element.getReferenceIds

Parameter Type Description
referenceIds EntityReferenceSet The Id64Set to populate with reference Ids.

Returns - void

Defined in

Last Updated: 16 April, 2024