createCode MethodStatic

Create a Code for a GeometryPart element given a name that is meant to be unique within the scope of the specified DefinitionModel.

createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code

@note GeometryPart elements are not required to be named (have a non-empty Code).

Parameter Type Description
iModel IModelDb The IModelDb
scopeModelId string The Id of the DefinitionModel that contains the GeometryPart element and provides the scope for its name.
codeValue string The GeometryPart name

Returns - Code

Defined in

Last Updated: 16 April, 2024