IModelHostOptions Interface

Options for IModelHost.startup

Implemented by

Properties

Name Type Description
appAssetsDir undefined | string The directory where application assets are found.  
authorizationClient undefined | AuthorizationClient The AuthorizationClient used to obtain AccessTokens.  
cacheDir undefined | string Root of the directory holding all the files that iTwin.js caches  
compressCachedTiles undefined | boolean Whether to compress cached tiles.  
enableOpenTelemetry undefined | boolean Whether to enable OpenTelemetry tracing.  
maxTileCacheDbSize undefined | number The maximum size in bytes to which a local sqlite database used for caching tiles can grow before it is purged of least-recently-used tiles.  
profileName undefined | string The name of the Profile subdirectory of IModelHostOptions.cacheDir for this process.  
restrictTileUrlsByClientIp undefined | boolean Whether to restrict tile cache URLs by client IP address (if available).  
tileCacheAzureCredentials undefined | AzureBlobStorageCredentials The Azure blob storage credentials to use for the tile cache service.  
tileCacheStorage undefined | ServerStorage    
workspace undefined | WorkspaceOpts Options for creating the Workspace  

Defined in

Last Updated: 15 March, 2024