bindValue Method

Binds a value to the specified SQL parameter. The value must be of one of these types:

JavaScript Type SQLite Type
undefined NULL
boolean INTEGER with true being bound as 1 and false as 0
number INTEGER if number is integral or REAL if number is not integral
string TEXT
Uint8Array or ArrayBuffer BLOB
StringParam where member id is set INTEGER
StringParam where member guid is set BLOB

bindValue(parameter: BindParameter, value: any): void

@throws IModelError if the value is of an unsupported type or in case of other binding errors.

Parameter Type Description
parameter BindParameter Index (1-based) or name of the parameter (including the initial ':', '@' or '$')
value any Value to bind.

Returns - void

Defined in

Last Updated: 16 April, 2024