ProcessDetector Class

Functions to determine the type of JavaScript process currently executing.

Methods

Name Description
constructor(): ProcessDetector    

Properties

Name Type Description
isAndroidAppBackend Accessor Static ReadOnly boolean Is this process the backend of an Android mobile application?  
isAndroidAppFrontend Accessor Static ReadOnly boolean Is this process the frontend of an Android mobile application?  
isAndroidBrowser Accessor Static ReadOnly boolean Is this process running in a browser on an Android device?  
isBrowserProcess Accessor Static ReadOnly boolean Is this a browser process?  
isChromium Accessor Static ReadOnly boolean Is this process running in a Chromium based browser (Chrome / new Edge / Electron front end)?  
isElectronAppBackend Accessor Static ReadOnly boolean Is this process the backend of an Electron app?  
isElectronAppFrontend Accessor Static ReadOnly boolean Is this process the frontend of an Electron app?  
isIOSAppBackend Accessor Static ReadOnly boolean Is this process the backend of an iOS mobile application?  
isIOSAppFrontend Accessor Static ReadOnly boolean Is this process the frontend of an iOS mobile application?  
isIOSBrowser Accessor Static ReadOnly boolean Is this process running in a browser on an iOS device?  
isIPadBrowser Accessor Static ReadOnly boolean Is this process running in a browser on an iPad?  
isIPhoneBrowser Accessor Static ReadOnly boolean Is this process running in a browser on an iPhone?  
isMobileAppBackend Accessor Static ReadOnly boolean Is this process a mobile app backend?  
isMobileAppFrontend Accessor Static ReadOnly boolean Is this process the frontend of an iTwin mobile application?  
isMobileBrowser Accessor Static ReadOnly boolean Is this process running in a browser on a mobile device?  
isNativeAppFrontend Accessor Static ReadOnly boolean Is this process the frontend of a native (Electron or Mobile) app?  
isNodeProcess Accessor Static ReadOnly boolean Is this a Node process?  

Defined in

Last Updated: 13 May, 2024