AmbientOcclusion.Props Interface

Describes the properties with which ambient occlusion should be drawn. These properties correspond to a horizon-based ambient occlusion approach.

Implemented by

Properties

Name Type Description
bias Readonly undefined | number If defined, represents an angle in radians.  
blurDelta Readonly undefined | number If defined, blurDelta is used to compute the weight of a Gaussian filter.  
blurSigma Readonly undefined | number If defined, blurSigma is used to compute the weight of a Gaussian filter.  
blurTexelStepSize Readonly undefined | number    
intensity Readonly undefined | number If defined, raise the final ambient occlusion to the power of this value.  
maxDistance Readonly undefined | number If defined, the maximum distance from the camera's near plane in meters at which ambient occlusion will be applied.  
texelStepSize Readonly undefined | number If defined, indicates the texel distance to step toward the next texel sample in the current direction.  
zLengthCap Readonly undefined | number If defined, if the distance in linear depth from the current sample to first sample is greater than this value, sampling stops in the current direction.  

Defined in

Last Updated: 16 April, 2024