fromJSON MethodStatic

Construct from JSON, performing validation and applying default values for undefined fields.

fromJSON(json?: BackgroundMapProps): BackgroundMapSettings

@see BackgroundMapSettings.fromPersistentJSON if you are reading the settings directly from the iModel.

Parameter Type Description
json BackgroundMapProps  

Returns - BackgroundMapSettings

Defined in

Last Updated: 16 April, 2024