MonochromeMode Enumeration

Describes the style in which monochrome color is applied by a DisplayStyleSettings.

Members

Name Value Description
Flat The color of the geometry is replaced with the monochrome color. e.g., if monochrome color is white, the geometry will be white.
Scaled The color of surfaces is computed as normal, then scaled to a shade of the monochrome color based on the surface color's intensity.
For example, if the monochrome color is white, this results in a greyscale effect.
Geometry other than surfaces is treated the same as MonochromeMode.Flat.

Defined in

Last Updated: 16 April, 2024