RenderSchedule.Interpolation Enumeration

Defines how two interpolate between two entries in a RenderSchedule.Timeline.

@note Currently only Linear and Step are supported. Any other value is treated as Step.

@see RenderSchedule.TimelineEntry.

Members

Name Value Description
Linear Given two entries on the timeline and a timepoint in between them, linearly interpolate based on the timepoint's distance between the
two entries.
Step Each timeline entry's value is discrete - the timeline jumps from one entry's value directly to another.

Defined in

Last Updated: 16 April, 2024