fromJSON MethodStatic

Create a ViewFlags from its JSON representation.

fromJSON(json?: ViewFlagProps): ViewFlags

@note As described in ViewFlagProps, the JSON representation is awkward and error-prone. Prefer to use ViewFlags.create unless you need to deal with the persistence format directly.

@note The default values differ slightly from those used by the constructor and ViewFlags.create:

Parameter Type Description
json ViewFlagProps  

Returns - ViewFlags

Defined in

Last Updated: 16 April, 2024