with Method

Produce a copy of these ViewFlags with a single boolean property changed.

with(flag: "fill" | "transparency" | "dimensions" | "patterns" | "weights" | "styles" | "textures" | "materials" | "acsTriad" | "grid" | "visibleEdges" | "hiddenEdges" | "shadows" | "clipVolume" | "constructions" | "monochrome" | "backgroundMap" | "ambientOcclusion" | "thematicDisplay" | "wiremesh" | "forceSurfaceDiscard" | "whiteOnWhiteReversal" | "lighting", value: boolean): ViewFlags

@returns A new ViewFlags with the property changed as specified, or this if the property already has the specified value.

@see - ViewFlags.withRenderMode to change the ViewFlags.renderMode property.

Parameter Type Description
flag "fill" | "transparency" | "dimensions" | "patterns" | "weights" | "styles" | "textures" | "materials" | "acsTriad" | "grid" | "visibleEdges" | "hiddenEdges" | "shadows" | "clipVolume" | "constructions" | "monochrome" | "backgroundMap" | "ambientOcclusion" | "thematicDisplay" | "wiremesh" | "forceSurfaceDiscard" | "whiteOnWhiteReversal" | "lighting" The name of the property.
value boolean The value to change the property to.

Returns - ViewFlags

A new ViewFlags with the property changed as specified, or this if the property already has the specified value.

Defined in

Last Updated: 16 April, 2024