ChangedElements Interface

Changed elements found in a changeset or between a range of changesets. All arrays in this object will have the same number of items. Each index for those arrays refer to the same element, e.g. to get the class Id of the element given by element Id changedElements.elements[index], you can use changedElements.classIds[index].

Properties

Name Type Description
classIds string[] ECClass Ids of elements that changed  
elements string[] Ids of elements that changed  
modelIds undefined | string[] Model Ids of the changed elements  
newChecksums undefined | number[][] After state checksums of the property value  
oldChecksums undefined | number[][] Before state checksums of the property value  
opcodes DbOpcode[] Operation that occurred on the element.  
parentClassIds undefined | string[] Parent ECClass Ids of the changed elements  
parentIds undefined | string[] Parent ids of the changed elements  
properties undefined | string[][] Property accessor strings of properties that changed, if any, for each changed element  
type TypeOfChange[] Type of change bitflags, see TypeOfChange  

Defined in

Last Updated: 16 April, 2024