GeometricModel3dProps Interface

Properties that define a GeometricModel3d

Extends

Properties

Name Type Description
isNotSpatiallyLocated undefined | boolean If true, then the elements in this GeometricModel3d are not in real-world coordinates and will not be in the spatial index.  
isPlanProjection undefined | boolean If true, then the elements in this GeometricModel3d are expected to be in an XY plane.  

Inherited properties

Name Type Inherited from Description
classFullName string GeometricModelProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
geometryGuid undefined | string GeometricModelProps A unique identifier that is updated each time a change affecting the appearance of a geometric element within this model
id undefined | string GeometricModelProps The Id of the entity.
isInstanceOfEntity Readonly undefined | undefined GeometricModelProps A non-existent property used to discriminate between EntityProps and Entity.
isPrivate undefined | boolean GeometricModelProps  
isTemplate undefined | boolean GeometricModelProps  
jsonProperties undefined | any GeometricModelProps Optional json properties of this Entity.
modeledElement RelatedElementProps GeometricModelProps  
name undefined | string GeometricModelProps  
parentModel undefined | string GeometricModelProps  

Defined in

Last Updated: 16 April, 2024