SheetTemplateProps Interface

Properties of a SheetTemplate

Extends

Properties

Name Type Description
border undefined | string    
height undefined | number    
width undefined | number    

Inherited properties

Name Type Inherited from Description
classFullName string ElementProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code CodeProps ElementProps The Code for this element
federationGuid undefined | string ElementProps A FederationGuid assigned to this element.
id undefined | string ElementProps The Id of the entity.
isInstanceOfEntity Readonly undefined | undefined ElementProps A non-existent property used to discriminate between EntityProps and Entity.
jsonProperties undefined | any ElementProps Optional json properties of this element.
model string ElementProps The Id of the Model containing this element
parent undefined | RelatedElementProps ElementProps The Parent of this element, if defined.
userLabel undefined | string ElementProps A user-assigned label for this element.

Defined in

Last Updated: 15 March, 2024