ViewAttachmentProps Interface

Properties for a ViewAttachment

Extends

Properties

Name Type Description
jsonProperties undefined | { clip?: ClipVectorProps, displayOptions?: { drawAsRaster?: boolean, preserveBackground?: boolean }, displayPriority?: number } Optional json properties of this element.  
view RelatedElementProps    

Inherited properties

Name Type Inherited from Description
category string GeometricElement2dProps The id of the category for this geometric element.
classFullName string GeometricElement2dProps The full name of the ECClass for this entity, in the form "Schema:ClassName"
code CodeProps GeometricElement2dProps The Code for this element
elementGeometryBuilderParams undefined | ElementGeometryBuilderParams GeometricElement2dProps How to build the element's GeometryStream.
federationGuid undefined | string GeometricElement2dProps A FederationGuid assigned to this element.
geom undefined | GeometryStreamProps GeometricElement2dProps The geometry stream properties
id undefined | string GeometricElement2dProps The Id of the entity.
isInstanceOfEntity Readonly undefined | undefined GeometricElement2dProps A non-existent property used to discriminate between EntityProps and Entity.
model string GeometricElement2dProps The Id of the Model containing this element
parent undefined | RelatedElementProps GeometricElement2dProps The Parent of this element, if defined.
placement undefined | Placement2dProps GeometricElement2dProps The placement properties
typeDefinition undefined | RelatedElementProps GeometricElement2dProps  
userLabel undefined | string GeometricElement2dProps A user-assigned label for this element.

Defined in

Last Updated: 16 April, 2024